
 

 

Effigydraw 
 

 

 

 

 

 

Creative guide for cliparts and backgrounds 
 

 



Creative guide for cliparts and backgrounds 2 

1. Cliparts, backgrounds and archives 
 

Effigydraw allow to place cliparts over an empty background or over a predefined background. This 

guide explains how you can create cliparts, backgrounds and archives of cliparts and backgrounds. 

 

Effigydraw proposes a gallery of cliparts. The application provides some cliparts but the user can 

add or download additional cliparts or create new cliparts and add them to the gallery. All that is 

needed is to copy the cliparts in the « Cliparts and archives folder » defined in the application 

parameter dialog window. When starting Effigydraw, all cliparts located in this folder are 

automatically added to the gallery. 

 

 

 
 

As it is easier to download a group of cliparts as a single file rather than each clipart separately, 

Effigydraw allows to group several cliparts inside an archive, which is a single ZIP file. Similarly to 

individual cliparts, if this archive is copied in the « Cliparts and archives folder » defined in the 

application parameter dialog window, all cliparts it contains will be added to the gallery. 

 

Effigydraw also proposes a gallery of backgrounds. As with cliparts, it is possible to create or 

download backgrounds, but these backgrounds will need to be embedded in an archive. The section 

3 explains how you can create backgrounds. 

The functions described in this guide are available in the advanced interface mode. 
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2.  Creating cliparts 
 

It is very easy to create cliparts because they are simple SVG drawings. 

1. Draw the clipart and save it as a normal drawing 

2. Move this SVG file in the « Cliparts and archives folder » defined in the application 

parameter dialog window 

3. At the next start of Effigydraw, the new clipart will be automatically added to the gallery. 

 

When a drawing is used as a clipart, the background is ignored and considered as transparent by the 

application. 

 

Note: 

It is possible to control the size of the cliparts when they will be placed on the drawing. The section 

5 describes how you can control the display size of the cliparts. 

 

 

In case the clipart is a part of a drawing, it is possible to save it independently. For example, in the 

drawing below, we could want to create a clipart from the polar bear. 
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The steps are the following: 

 

1. The first step is to form a group containing the part of the drawing of which you want to create a 

clipart.  For it, select all the objects that constitute the polar bear, click on the right button of the 

mouse and chose « Group » in the contextual menu. 

 

 

 
 

2. Once the group is created, select it and save it with the function «Save group as clipart» from the 

File menu. 

 

 

 
 

3. Move this SVG file obtained in the « Cliparts and archives folder » defined in the application 

parameter dialog window 

4. At the next start of Effigydraw, the new clipart will be automatically added to the gallery. 
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3.  Creating a background 
 

A background is also a simple drawing as the cliparts. But for Effigydraw to load a background, it is 

necessary to save it in an archive file. Here is how to proceed: 

 

1. Draw a background 

2. Call the function « Save as archive » of the File menu 

 

 

3. Effigydraw opens a pop-up dialog that prompts you to optionally define the title, the author 

name and the version of the archive that will be created. 

 

 

 
 

 

4. Move the ZIP file obtained in the « Cliparts and archives folder » defined in the application 

parameter dialog window 

5. At the next start of Effigydraw, the new background will be automatically proposed in the 

Effigydraw explorer. 
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Note: 

It is possible to control the size of the cliparts when they will be placed on the background. The 

section 5 describes how you can control the display size of the cliparts. 

 

 

4.  Creating archive files 
 

Archive files allow to group in a single file several cliparts and several backgrounds. It is also very 

interesting to use archives if you want to control the size of the cliparts when they will be placed on 

the background. The section 5 describes how you can control the display size of the cliparts. 

 

The simplest way to create archives is similar to the method described to create a background. Let's 

say that we want to create an archive containing one background and three cliparts, the polar bear, 

the sea lion and the penguin as in the drawing below. 

 

 

 
 

Here is how to proceed: 

1. The first step is to form a group for each part of the drawing of which you want to create a 

clipart, that is to say a group for the polar bear, a second one for the sea lion and a third one for the 

penguin.  For it, select all the objects that constitute the polar bear, click on the right button of the 

mouse and chose « Group » in the contextual menu. Repeat these steps for the two other cliparts. 
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2. Then define this group as a clipart. For it, launch the function “Edit group properties” of the 

Format menu and check “Clipart”. It is possible to control the size of the cliparts when they 

will be placed on the background. The section 5 describes how you can control the display 

size of the cliparts. 

 

 
 

3. Once the group are created, call the function « Save as archive » of the File menu 
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3. Effigydraw opens a pop-up dialog that prompts you to optionally define the title, the author name 

and the version of the archive that will be created. Once Ok is clicked, Effigydraw will create an 

archive file where all the groups you defined as cliparts will be converted as cliparts and the other 

objects will constitute the background. 

 

 
 

4. Move the ZIP file obtained in the « Cliparts and archives folder » defined in the application 

parameter dialog window 

5. At the next start of Effigydraw, the new background will be automatically proposed in the 

Effigydraw explorer and the three cliparts will be added to the gallery. 
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Effigydraw is offering another function allowing to create an archive with several backgrounds. 

 

Here is how to proceed: 

1. Draw the cliparts and save them in a folder that will contain all the cliparts that you want to 

include in the archive. 

2. Draw the backgrounds and save them in another folder that will contain all the backgrounds 

that you want to include in the archive. 

3. Launch the function « Create an archive of cliparts » in the Tools menu 

 

 
 

4. This function opens a pop-up dialog that prompts you to specify the name of the folder 

containing the cliparts, the name of the folder containing the backgrounds and the path and 

filename of the archive. You can also optionally define the title, the author name and the 

version of the archive that will be created. 

 

 
 

 

5. Launch « Create an archive » 
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6. Move the ZIP file obtained in the « Cliparts and archives folder » defined in the application 

parameter dialog window 

7. At the next start of Effigydraw, the new background will be automatically proposed in the 

Effigydraw explorer and the three cliparts will be added to the gallery. 

 

 

 

5.  Controlling the display size of cliparts 
 

Effigydraw allows to control the size of cliparts when they are placed over a background. 

 

The size is expressed as a percentage of the size of the background. For example, for a 300 pixels 

wide and 200 pixels high background, a clipart which size is 15% of the background will exactly fit 

within a rectangle of 45 pixels wide (15% of 300 pixels) by 30 pixels high (15% of 200 pixels). 

 

 

 
 

The parameters for controlling the size of the cliparts are accessible through the function 

« Document information » of the File menu when you create a clipart or a background. 
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You can use this function in different situations. 

 

 

For setting the size of a clipart compared to the background 
The first situation is the one where the designer of an archive containing cliparts and one or several 

backgrounds wants that the cliparts of its archive have a given size when the user will place them 

over a background from the same archive. 

 

For it, when you create a clipart, launch the function « Document information » of the File menu, 

select « Clipart » then check the option « Size of clipart in Background » and chose the size of the 

clipart. This value is expressed as a percentage of the size of the background and is applicable to all 

backgrounds of the same archive. 
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In case of the creation from the function « Save as archive » of the File menu of an archive 

containing a single background , the cliparts will be saved with their attribute « Size of clipart in 

Background » computed automatically so that the clipart will keep the same size when they are 

placed on the background by the user. 

 

 

When an archive contains several backgrounds, it is possible to set a different insertion size of the 

clipart for each background. 

For it, when you create a clipart, launch the function « Document information » of the File menu, 

select « Clipart » then check the option « Size for a list of backgrounds ». You will have then to 

provide Effigydraw with the list of sizes as pairs <background name>:<clipart size> separated by 

semicolons. Size of cliparts are expressed as a percentage of the size of the background. 

For example: 

decor1.svg:20%;decor2.svg:30% 
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For setting the default size of cliparts placed over a background 
 

In the previous case, the clipart we want to control the display size is part of the same archive as the 

background over which it will be placed. In the second situation, the designer of a background 

wants to control the size of any clipart of the gallery that is not part of the archive containing the 

background, when these clipart will be placed over the background. For example, the designer may 

want that by default, the clipart that are not associated to the background (not in the same archive) 

are displayed with a size of 10% of the background. 

For it, when you create a background, launch the function « Document information » of the File 

menu, select « Background » then check set the value « Clipart insertion size ».This value is 

expressed as a percentage of the size of the background. It is applicable to all cliparts that are not in 

the same archive as the background but also for cliparts of the same archive if their size has not be 

configured. 

 

 

 
 

 

 

For setting the relative size of cliparts placed over a background 
In a first situation, the clipart designer wants to control the relative size of the cliparts when they are 

placed over any background. For example, a tree or an house should be displayed bigger than an 

animal or an object. 
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To achieve this, when you create a clipart, launch the function « Document information » of the File 

menu, select «Clipart» then set the value « Scaling factor » of the clipart. This value must be 

between 0.1 and 10 : the value 1 corresponds to the default size, a value 2 of a clipart two times 

bigger and a value 0.5 two times smaller. 

It is used by Effigydraw when the clipart is not part of the same archive as the background or if it is 

part of the same archive but the parameters « Size of clipart in Background » and « Size for a list of 

backgrounds » have not been filled. 

 

 
 

 

In case an archive is created from the function « Save as archive » of the File menu, it is possible to 

control the relative size of each group that has been defined as clipart. Launch the function “Edit 

group properties” of the Format menu, check “Clipart” then select the « Scaling factor » of the 

clipart. 
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How Effigydraw computes the size of a clipart 
 

Here is how Effigydraw sets the display size of a clipart when it is placed over a background. It 

selects the first true condition. 

 

 1. If the clipart is part of the same archive as the background. 

 a) Effigydraw first check if the parameter « Size for a list of backgrounds » of the clipart is 

set and if the list contains the actual background. If yes, the size associated to the 

background is used. 

 b) If the parameter « Size of clipart in background » of the clipart is set, this value is used. 

 c) If none of these parameters is set, Effigydraw will use the value of the parameter 

« Clipart insertion size » of the background if this value is set. In that case, it will also 

apply the parameter « Scaling factor » of the clipart. 

 d) Otherwise, a default size of 15% multiplied by the value of the parameter « Scaling 

factor » of the clipart will be applied. 

 2. In case the clipart is not part of the same archive as the background : 

 a) Effigydraw will use the value of the parameter « Clipart insertion size » of the 

background if this value is set. In that case, it will also apply the parameter « Scaling 

factor » of the clipart. 

 b) Otherwise, a default size of 15% multiplied by the value of the parameter « Scaling 

factor » of the clipart will be applied. 

 

 

In case the user did not use a pre-defined background but instead started from a blank background, 

Effigydraw will select the size of the clipart based on the configuration of the user interface (S, M 

or L). The value of the parameter « Scaling factor » of the clipart will also be applied. 

 

These rules are not applicable to the advanced interface mode. In this mode, the size is directly set 

by the user. 
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6.  SVG attributes 
 

Effigydraw uses attributes of the « svg » element to control the size of the cliparts when placed over 

a background. 

 

The following SVG fragment is an example of use of these attributes for a clipart. 

 
<svg xmlns="http://www.w3.org/2000/svg" 

     xmlns:xlink="http://www.w3.org/1999/xlink" 

     xmlns:effigydraw="http://www.effigydraw.fr/"  

     version="1.1" baseProfile="none"  

     effigydraw:version="1.0"  

     effigydraw:layer="clipart"  

     effigydraw:clipart-scaling="1.2"  

     effigydraw:clipart-background-ratio="12.0%"  

     effigydraw:clipart-backgrounds-ratio-list="decor1.svg:20%;decor2.svg:30%"  

     width="600px" height="500px" style="background-color:#FFFFFF"> 

 

And this second SVG fragment is an example of use of these attributes for a background. They 

allow to control the default size of cliparts over the background. 

 
<svg xmlns="http://www.w3.org/2000/svg" 

     xmlns:xlink="http://www.w3.org/1999/xlink" 

     xmlns:effigydraw="http://www.effigydraw.fr/"  

     version="1.1" baseProfile="none"  

     effigydraw:version="1.0"  

     effigydraw:layer="background"  

     effigydraw:background-insertion-size="12.0%"  

     width="600px" height="500px" style="background-color:#FFFFFF"> 

 

 

Definition of the attributes: 

 

 

effigydraw:layer = "clipart | background" 

 The value clipart should be used when the drawing is a clipart and the value background 

when a background 

 

effigydraw:clipart-scaling = "<scaling factor >" 

This attribute is used to control the relative size of cliparts placed over a background. This 

attribute will only be applicable to cliparts. It will be ignored if the SVG drawing is a 

background. 

The scaling factor is a number between 0.1 and 10. If this attribute is not specified, this will 

have the same effect as if it is specified with a value of 1. 

 

 

effigydraw:clipart-background-ratio = "<size of clipart in background >" 

This attribute is used to set the size of a clipart when used with backgrounds of the same 

archive. This attribute will only be applicable to cliparts. It will be ignored if the SVG 
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drawing is a background. The parameter « size of clipart in background » is a percentage 

with a value between 1% and 100%. The value must end with the '%' character. 

If this attribute is not specified, this will have the same effect as if it is specified with a value 

of 15%. 

 

 

effigydraw:clipart-backgrounds-ratio-list = "<size for a list of backgrounds>" 

This attribute is used to set the size of a clipart for several backgrounds of the same archive 

and with different values. This attribute will only be applicable to cliparts. It will be ignored 

if the SVG drawing is a background. The value of this attribute is a list of pairs 

<background name>:<clipart size> separated by semicolons. Size of cliparts are expressed 

as a percentage of the size of the background. The percentages must be value between 1% 

and 100% and must end with the '%' character. For example: 

decor1.svg:20%;decor2.svg:30% 

 

  
effigydraw:background-insertion-size = "<clipart insertion size>" 

This attribute is used to set the default size of the cliparts placed over a background. This 

attribute will only be applicable to backgrounds. It will be ignored if the SVG drawing is a 

clipart. Its value is a percentage between 1% and 100% and must ends with the '%' 

character. If this attribute is not specified, this will have the same effect as if it is specified 

with a value of 15%. 
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